CPU Replacement

  • Curious if anyone knows if the CPU is user-replaceable in the COM-HPC-ALT Server Module, atleast within the Altra and Altra Max sub-families. I would like to evaluate potential application of the Ampere Altra/Max in off-grid situations with TDP vs Core count being a metric. Apparently Adlink does not market the COM-HPC module without a CPU, so it seems likely the module itself has to be hardware configured for the cpu frequency. I have a spare M128-30 that I would have liked to have tried in one of these modules, and don't want to spring for whole CPU+COM+Carrier and then end up with another "spare" CPU with nothing to use it in. Asrock Rack does have their ALTRAD8UD-1L2T small server motherboard, slated for distribution next quarter, that shows promise for my applications.

  • Hi Andrew,


    we won't suggest the user replaces the CPU by self, maybe it will cuase the system damaged and further the system cannot be boot normally

    in addition, you also would lose the warranty after the system damaged

    please think twice before replacment


    Best Regards,


  • @Tu Ken Hi, I have successfully replaced my original Q32-17 to Q80-30, but after my replacement ,  the Q80-30 cpu can only run on 2.3GHz frequency. How to let it run in max frequency?




  • @Jiaheng Wang maybe you're facing the same problem as I am in this thread: https://www.ipi.wiki/community/forum/topic/100157/cpu-frequency-capped-to-23-ghz-instead-of-26-ghz


    Here it's a Q80-26 and it tends to boot at 2.3 most of the time, and only sometimes it finally switches to 2.6. Today after an intensive network test, it went down to 1.0 and stays there. I'll reboot to see if that fixes it. It's getting extremely annoying at this point, the hardware cannot be trusted at all when running tests :-(


  • @Willy Tarreau I also do some test, I found only a portion of cores can reach the 3GHz, if the load goes high, all cores will drop to 2.3GHz max. It seems that the module maybe have some limit on the power consumption of CPU. But I notice another guy using M96-28 on an AADP, and it can perform the max frequency:


    Don't know how to achieve the performance like that.

  • @Willy Tarreau Conclusion: This is actually a firmware issue. After update to the latest release of edk2 (v2.09.100.00 on 20231031), Now my Q80-30 can running on all core at 3.0GHz now, and the GB5 score is almost same as others. https://browser.geekbench.com/v5/cpu/21899311

  • @Jiaheng Wang yeah I know that Jeff has all his cores at full speed, which also makes me think it's related to the module itself. On the other thread I mentioned, a person said she was working on the ACPI firmware, so that's definitely among the things that can explain all this.

  • @Jiaheng Wang our messages have crossed, for an unknown reason your latest one was only refreshed after I posted mine. Very interesting for the firmware, I'll definitely have a look, thank you! Just as a reminder, how did you proceed for the update ? I did it only once several months ago and just forgot :-(

  • @Willy Tarreau You can reffer to this document: https://www.ipi.wiki/pages/aadk-docs?page=firmware_Flashing-EDKII-SCP.html

    And the newest firmware can be found on Adlink's github : https://github.com/ADLINK/edk2_aadp/releases

    Also, you should know that update edk2 using Capsule is a one-way trip. You can't downgrade to a lower version. If you want to flash back to a lower version, you will need the DB40 board.


  • @Jiaheng Wang much appreciated, thank you!


  • OK that worked, thanks again!

    However now I'm having a serious problem with this upgrade, the system is ultra-long to boot (7 minutes of silence, with sometimes a few rare "PROGRESS" codes on the console), and the RAM is reported as "0 MB" in the BIOS main screen. I'm going to report that to the github project.  All that to say that one must be very careful with this version!

  • @Willy Tarreau I met your situation, too. But Unfortunately, I just can't downgrade firmware from 2.09 to 2.04 using Capsule. I'm tring to use the bios on the carrier by setting some Jumpers on the carrier, but with no success now. I'm currently finding a way to use the DB40 port to directly program the bios chip on the module. If it works, I will update a guideance. Hoping the next release will solve this bug.

  • Btw, the edk2_aadp github repository above doesn't exist anymore. There are other ones, all older than 2.09.100, so I'm not sure ADLINK is uploading firmwares on github anymore.

  • @Willy Tarreau The edk2_aadp repo was temporarily removed because they found problems where older hardware revisions could be bricked. They're updating the documentation and will make it visible again soon.

  • FWIW the repository is back online with updates, and the new image in the download area managed to boot and restore my machine.

Please login to reply this topic!