get driver CP210x for IMX8MP Debian10 version

  • Hello, I flashed a Debian Image to the SD Card.

    and I need CP210x driver for my sensor, but i can not find it.

    When I execute '$ lsusb', the output is "Cygnal Integrated Products, Inc. CP2102/CP2109 UART Bridge Controller [CP210x family]". Howerver, there is no 'ttyUSB*' for this sensor.

    This issue is not related to 'ttyUSB*' because I can find other sensors under 'ttyUSB*'.

    I think this is the problem that there is no cp210x driver. 

    Actually, when I run '$ls -al /lib/modules/"$(uname -r)"/kernel/drivers/usb/serial/cp210x.ko', then output is "ls: cannot access '/lib/modules/5.10.35-lts-5.10.y+gc990fdc2ac56/kernel/drivers/usb/serial/cp210x.ko': No such file or directory".

    How can i solve this problem?

    I tried to build cp210x for solving this problem. I downloaded "Linux 3.x.x/4.x.x/5.x.x VCP Driver" on

    But when I run "$ make", And i got Error 'modpost: "__stack_chk_guard" [/home/imx8mp/Downloads/driver/cp210x.ko] undefined!'. I think this is about Kernel things..

    I do not have access to PCs that meet the recommended hardware requirements for the host. Therefore, I cannot choose other solutions like building Yocto or something similar. I can only use rufus.exe.

    Thank you for reading this.

  • Dear @Haeseul Shin,

    Root cause

    "__stack_chk_guard" refers to a symbol related to stack-checking functionalities in the kernel.

    [/home/imx8mp/Downloads/driver/cp210x.ko]: This specifies the path to the compiled kernel module file (cp210x.ko) causing the issue.

    undefined!: This indicates that the modpost tool cannot find the "__stack_chk_guard" symbol within the module file.


    Double-check the documentation for the downloaded driver to see if it explicitly mentions compatibility with your kernel version (e.g., Linux 3.x.x, 4.x.x, or 5.x.x).

    Consider searching(alternative driver) for a cp210x driver compiled explicitly for your kernel version.

    If it is a kernel version compatibility issue, upgrade the kernel and try to install it again.

Please login to reply this topic!