Synchronous Exception at 0x00000000F8222CF4

  • Sadly the message says it all. That's what I'm getting after the "Press Escape for boot options" in EDK2 if I don't press anything. If I press Escape, then the machine hangs.

    I tried the following:

    - remove all SSDs

    - remove all but 2 DIMMs

    - change the remaining DIMMs

    - touch JP27/28/29 to try to boot from an alternate BIOS.

    The BIOS had been updated to 2.09.100 a month ago to fix some frequency issues (it's a Q80-26 which used to drop to 2.3 GHz regularly and even to 1.0 sometimes). It hasn't happened since the update, but it did take ages to boot.

    I just wanted to replace a NIC this afternoon, so I halted the system, powered it off, and never managed to boot it anymore. There are no other messages on the serial console (apart the usual CPxxx, PROGRESS xxx, and finally the same Synchronous Exception as I'm getting on the VGA monitor).

    I have no idea what else to try, I spent 4 hours on it now (thanks to its awfully slow boot which prevents you from testing settings). The 7-seg display on board shows 9A. I couldn't find any info about this message on the net except some RPi users having boot issues.

    I hoped to be able to get a UEFI shell and maybe flash a more recent BIOS but the project was removed from github (why on earth would a hardware vendor remove BIOS updates?) and anyway I can't manage to get a shell on it. I'm even wondering if it could be a CPU issue, but I don't want to disassemble anything for now. I'm at a point I'm taking on my nerves not to throw it by the window :-(

    If anyone from Adlink has any idea, that would be nice, because while that machine is awesome once it's booted, you still need to manage to boot it and I never saw that capricious a machine! Even my old VAX and a Sun E450 are nicer in comparison!

    Thanks in advance!


    PS: notifications don't work on the forum and I lost several responses that I discovered much later. Feel free to ping me at, even for complements of info.

  • Dear @Willy Tarreau, We took it down for a few days to reconstruct the repo. Now, we've opened it for you. Sorry for the inconvenience. Please downgrade your BIOS version to which is the stable version right now. you can expect by next week. 2.09 is only for validation purposes it might have some bugs. We will reconstruct our repo ASAP.

  • A new MMC will be released this week. May be you can get it from staff in advance. The new 2.09 MMC will let you to use BIOS on carrier by setting JP27-29, maybe that can solve your problem.

  • Thank you! The problem I'm facing is: how will I be supposed to flash this given that I can't get past the BIOS anymore ? I do have a buspirate board at home with the SPI adapter for SOP-8, and have used flashrom in the past, so if really needed, with suitable instructions I can try to directly reprogram the flash.

  • Just to share some updates, I could reflash the MMC from the default image ipmitool as documented somewhere else in the wiki. So my understanding is that after the next update, it will be able to load from the alternate SPI. I'll keep an eye on it, since the machine is bricked for now anyay. Thanks for the hint!

  • @Willy Tarreau @Jiaheng Wang was able to create an adapter to connect from a SPI programmer to the DB40 connector on the module, which might be useful?


  • @Rebecca Cran thanks for the info. We'll see, for now I don't have any DB40-to-FPC adapter. I understood that the upcoming 2.09 MMC code will support JP27-29 to allow to load EDK2 from the carrier board, so if that works I won't need to flash the module's SPI flash, and I may just need to flash the carrier's instead. I haven't opened it yet but it looks like a pretty regular SOP-8 NOR, and I already have an adapter for these, which is why I'm hopeful :-)

  • @Willy Tarreau Very helpfully, the EEPROMs on the carrier board are all socketed so you can either use an adapter to flash them in-place, or remove them and flash them outside the case.

  • @Rebecca Cran yeah, when I said "not opened it yet", I meant the EEPROM socket :-)

  • Just to inform other users that after the last update in the download area with MMC 2.09 and EDK2, I managed to flash the SPI NOR on the carrier board using an external programmer, and to boot from it by moving JP27 to 2-3. The board works again, indicating that the problem was only related to the UEFI image.

    By the way I have been thinking about something, I saw in the BIOS that there's a watchdog enabled by default, given how slow the boot is, I wouldn't be surprised if the watchdog triggers shortly after the "press escape" moment.

    I tried to reflash the EDK2 firmware from USB once booted from the carrier board, but it only reflashed the one on the carrier board. I thought about moving JP27 after boot but haven't tried yet.

    When I saw it boot from the bad EDK2 again on the module, I thought I should try again, since the BIOS settings likely have been erased with the upgrade. It seems I was right, because I managed to get it to boot again, so I could enter the boot manager to reach the UEFI shell and flash the EDK2 on the module.

    So... nothing trivial but at least I think my machine is recovered now. Thanks to the staff for providing the MMC 2.09 update that allows to boot from the carrier board SPI!

Please login to reply this topic!