[Help Needed] Need the Definition of DB40 connector of A2 board.

  • FWIW I've reprogrammed edk2 2.06  on the carrier board's SPI and moved JP27 to 2-3 so that I can now boot 2.06 by default. The board boots faster than with 2.09 (i.e. about less than one minute) and the CPU frequency is correct. I once had a crash while touching some PCIe options in the BIOS but that's all. I count on leaving it like this for now.

    Indeed I have not updated the BMC version, given that I wanted to unbrick the board before taking more risks, and was counting in the BMC to be able to flash the MMC code. Maybe that's something I should do next.

    I must say that it's difficult for the end user to figure what versions are expected to be stable and which ones are not. After having bricked the board by flashing something I thought was stable, I'm becoming much more cautious about flashing now.

    Also it's a bit sad that several tags were not produced as releases (e.g. I tried to build the images myself and discovered that they can only be built by Adlink employees since they refer to internal hosts and stuff that's not available. So I think it would be very useful to periodically produce development images that some users could test (e.g. weekly). You'd get more reports about them, and by making it clear which ones are stable or dev, there would be much less risk that users flash a development image by accident (e.g. call them -dev, -experimental or -beta).


  • @Willy Tarreau The ADLINK firmware images can be built by end users if they have an NDA signed by Ampere which provides access to the SCP and TF-A binary blobs. The AmpereAltra-ATF-SCP repository in ADLINK is private because it contains those files which can't be publicly released.


    If you can sign an NDA with Ampere, I have a script which makes building the ADLINK firmware much simpler (https://github.com/bcran/edk2_aadp/blob/bcran-adlink-fw-changes/bld.sh). Personally, when I clone https://github.com/ADLINK/edk2_aadp I just do a "git rm AmpereAltra-ATF-SCP` to avoid having it complain about not being able to access that submodule.

  • @Rebecca Cran OK that's good to know, but I'm definitely not interested in going down that route. Signing an NDA for the sole purpose of getting a board to properly boot is a bit excessive :-)  Now with 2.06 it seems to work fine, I'll leave it with that one and consider the problem solved for now.

    Thanks for the info anyway ;-)


  • 1
  • 2 / 2
Please login to reply this topic!